gem of death

 Thu, 12 Mar 2015 19:48:41 +0100 
How can people work with #ruby actually? Or am I the only one who is fucked every time using some ruby gems? :-!
This morning I did a vagrant destroy; vagrant up which provisions among other things a ruby tool (mailcatcher) and everything worked.
I did a vagrant destroy; vagrant up this afternoon and suddenly the ruby program don't want to install anymore because some gems are not compatible anymore with the rest. WTF?!? :facepalm
:headbang :headbang :headbang

Feel welcome to Ruby

 Tue, 07 Oct 2014 16:28:10 +0200 
I should feel pity for everyone who has to work with #Ruby and rubygems. What a fucking dependency and incompatibility hell.

I used to install mailcatcher through gem install in my Vagrant provisioning scripts for a long time. Suddenly a dependency requires a newer Ruby version than what is available on CentOS6. On CentOS7 it still works, but installs another dependent package in a version that causes Encoding::CompatibilityErrors. Installing an older version of the package and everything is fine. And yet another runtime dependency is not installed by gem and needs to be installed manually. Oh and in CentOS6 gem installs it to /usr/bin in CentOS7 suddenly to /usr/local/bin #WTF?!?

At least I can handle all this in a Puppet module and reuse it, but why must these scripts get so fucked up? :-!

Ruby what a mess

 Sat, 22 Feb 2014 13:12:19 +0100 
Installed vagrant yesterday and it worked. Installed some system updates today. Vagrant does not run anymore because of missing dependencies on a lib:
Could not find 'net-ssh' (< 2.8.0, >= 2.6.6) - did find: [net-ssh-2.8.0,net-ssh-2.2.2,net-ssh-2.1.4]
This is not the first version compatibility problem I had with #Ruby. WTF? :-!